Home » RDBMS Server » Backup & Recovery » 99.recovery using rman
99.recovery using rman [message #69987] Tue, 26 March 2002 18:38 Go to next message
krishna
Messages: 141
Registered: October 1998
Senior Member
I did a consistent whole database backup(using rman). I then deliberately deleted one datafile of this database. Now i'm trying to recover the database(using rman). I realise that before trying to restore, i need to allocate a channel.
I tried this.
run { allocate channel t1 type disk; } and it worked.
RMAN-03022: compiling command: allocate
RMAN-03023: executing command: allocate
RMAN-08030: allocated channel: t1
RMAN-08500: channel t1: sid=13 devtype=DISK
RMAN-08031: released channel: t1

Now i gave
recover database;
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00558: error encountered while parsing input commands
RMAN-01005: syntax error: found "recover": expecting one of: "allocate, alter, beginline, catalog, change, connect, create, crosscheck, configure, debug, delete, drop, exit, endinline, host, {, library, list, mount, open, print, register, release, replace, report, renormalize, reset, resync, rman, rpct·"
Can u help?
I find that the syntax for doing backup and recovery is not available anywhere.
Any u suggest any url which might be of use to me?
This way i might not have to trouble u frequently :-)
Re: 99.recovery using rman [message #69989 is a reply to message #69987] Wed, 27 March 2002 03:59 Go to previous message
Grant
Messages: 578
Registered: January 2002
Senior Member
run {
allocate channel t1 type disk;
restore (database);
recover database;
sql 'alter database open resetlogs';
}
Previous Topic: 98.retrieving datafile using rman
Next Topic: how to delete rman catalog?
Goto Forum:
  


Current Time: Thu Dec 01 13:53:58 CST 2022